Unable to purchase credits
Incident Report for Brego
Resolved
Our third party payment provider has pushed a fix, credit purchases should now work again.
Posted Mar 26, 2022 - 21:02 UTC
Identified
We have identified an issue with our third party payments provider and are working with them to fix the issue
Posted Mar 26, 2022 - 19:46 UTC
Investigating
We are currently investigating an issue where some users are unable to purchase credits
Posted Mar 26, 2022 - 19:25 UTC
This incident affected: Platform.